BIODIESEL & SVO DISCUSSION FORUMS





Sponsors    Biodiesel and SVO Forums Home    Forums  Hop To Forum Categories  Biodiesel  Hop To Forums  Biodiesel Safety    GM 6.5TD Not Pumping Fuel To Racor Filter
Go
New
Find
Notify
Tools
Reply
  
GM 6.5TD Not Pumping Fuel To Racor Filter
 Login/Join
 
Member
posted
All
I am on my 3rd tank of B100 and on my 1998 Suburban I have changed 2 filters and found some crud in the bottom of the Racor filter. Last night I got the water light and drained the bottom of the filter multiple times and after this the lift pump would not pump BD to the Racor filter. I can hear the lift pump running, but it doesn't stay on very long and nothing is getting pumped to the Racor Filter. I fear I have some crud plugging something somewhere. I have soap tested my BD on the 50/50 test and it has tested good, but my BP190 went down on me in the middle of my last batch (surge from lightning). I had to finish washing/drying the batch manually with bubble method and heat.
My fuel lines are original: do I start with them? I have a 1997 Tahoe with the exact engine and it is running fine on the same fuel with no issues and the fuel lines are at least a year older. The lift pump is getting fuel to the Racor Filter on the 97 Tahoe.
Any help appreciated.

Mark Magee
Brady TX


BioPro 190
Biodiesel Newbie
98 Suburban 6.5
97 Tahoe 6.5
 
Location: Central Texas | Registered: March 22, 2011Reply With QuoteReport This Post
Member
posted Hide Post
I can relate to 6.5 problems, boidiesel or not, I have had nothing but trouble with mine. It sounds like it is not a fuel problem if one car is running and the other isn't. Everything on that engine seems to be two things. the oil pressure sensor, and the ecm-b fuse under the hood. if either one of those is bad, you won't get fuel for more than a few seconds. Now, this is going to sound stupid, but you may also have a ground problem. Before I did anything else to this engine, like replacing stuff. I would take every ground apart I could find and clean it till it shines, and put it back together. I'm talking not just battery terminals, but battery to frame, battery to engine, frame to cab. a bad ground will cause it to act like a lot of other things. bad pump driver, bad lift pump, bad oil sensor, or bad ecm. The 6.5 is a great engine, however, the electrical system is the worst of any car I have ever been around.

another thing you can try, is to put the lift pump on a switch. mine is wired up on a switch and a relay, so you can turn on the lift pump manually for priming filters during filter changes. If you still don't get fuel with the lift pump running, you either have a dead pump that still makes noise, or you have a plugged up pickup screen in the tank. best you can do in that case, is blow backward with air.
what kind of racor filter do you have? my ventrac comes stock with r-12 filters, and they do not like biodiesl. something in the bio doesn't like the waterblock coating on the filter paper, and they will plug up in a few hours. (it's not water, we don't water wash.) I took off those filters, and put on a bobcat filterhead. Problem solved.
hope this stuff helps, my car has been towed 6 times in the last 18 months, if I hit 7, I'm putting in a 4bt cummins, no more wiring!


powering
2 bobcats, an excavator, and a ventrac mower. looking for a diesel weedeater!
 
Location: morgantown wv | Registered: June 18, 2008Reply With QuoteReport This Post
Member
posted Hide Post
Just because you hear the lift pump running does not mean its working.See if you have any fuel coming from the t valve up front,if there is none then you have a lift pump that is not working.Should pump even when the engine is not running.
 
Registered: September 16, 2005Reply With QuoteReport This Post
  Powered by Social Strata  
 

Sponsors    Biodiesel and SVO Forums Home    Forums  Hop To Forum Categories  Biodiesel  Hop To Forums  Biodiesel Safety    GM 6.5TD Not Pumping Fuel To Racor Filter

© Maui Green Energy 2000 - 2014