BIODIESEL & SVO DISCUSSION FORUMS





Sponsors    Biodiesel and SVO Forums Home    Forums  Hop To Forum Categories  Diesel vehicles and other diesel equipment  Hop To Forums  6.6 Duramax    Medium Duty Duramax problems

Moderators: Shaun, The Trouts
Go
New
Find
Notify
Tools
Reply
  
Medium Duty Duramax problems
 Login/Join
 
Member
posted
I am looking for any info on the following problem. I have a 2005 C5500 with the 6600 Duramax. This is a medium duty truck. I keep getting the code for low fuel rail pressure. This usually indicates a clogged filter, but the fuel vacuum test indicates that the filter is not plugged. Either way, the code will pop again even after changing the filter.
The dealership tested it and found that the vacuum jumped from 3 inches to 18 inches when the engine reached about 3000 RPMs. They replaced the filter housing, the lines to the pump and the fuel regulator. This fixed it for about 1000 miles.
When it does pop a code, it goes into limp mode. If I shut the truck down for about a minute, it can be restarted and run normally as long as I don't let the RPMs climb too high.
Since this is a medium duty truck that weighs a fairly constant 19000 lbs, trying to drive with out going to the high RPMs is near impossible. Any Suggestions?
Thanks
 
Registered: November 18, 2008Reply With QuoteReport This Post
Member
posted Hide Post
Hi Abe. This seems to be an inherant problem w/ the 05 series, its all about RPM. A friend of mine gets this all the time pulling his 5th wheel. I have an 04 and an 06. The 04 went thru the inj. upgrade but now is fine. Anyway check w/ Banks Power, they may be able to help with your computers mind modification. Good luck.
 
Location: Valley Center | Registered: August 02, 2008Reply With QuoteReport This Post
Member
posted Hide Post
Same thread 2 times?

Also here.
http://biodiesel.infopop.cc/ev...1057422/m/2511003972


________________________________________________________
Has anyone converted a W210 Mercedes to use SVO?
http://biodiesel.infopop.cc/ev...=857104535#857104535
 
Location: Arlington, Va.  | Registered: October 14, 2009Reply With QuoteReport This Post
Member
posted Hide Post
quote:
Originally posted by Abe's Toolbox:
I am looking for any info on the following problem. I have a 2005 C5500 with the 6600 Duramax. This is a medium duty truck. I keep getting the code for low fuel rail pressure. This usually indicates a clogged filter, but the fuel vacuum test indicates that the filter is not plugged. Either way, the code will pop again even after changing the filter.
The dealership tested it and found that the vacuum jumped from 3 inches to 18 inches when the engine reached about 3000 RPMs. They replaced the filter housing, the lines to the pump and the fuel regulator. This fixed it for about 1000 miles.
When it does pop a code, it goes into limp mode. If I shut the truck down for about a minute, it can be restarted and run normally as long as I don't let the RPMs climb too high.
Since this is a medium duty truck that weighs a fairly constant 19000 lbs, trying to drive with out going to the high RPMs is near impossible. Any Suggestions?
Thanks


Sorry I'm so late to the party. I trust you got this figured out? If not, I could probably help...


Dave

Making/running B100
07 Duramax LBZ
06 Jetta TDI
Spend most my time on www.dmaxcentral.com - duramax forum
 
Location: Mesa, Az  | Registered: June 21, 2010Reply With QuoteReport This Post
Member
posted Hide Post
I am having the same problem with my 2005 4500. Even running 25% bio will cause the problem. I have a 2004 F250 and have been running the same fuel at 100% for 32,000 miles without a glitch. Has anyone figured out this problem with the 6.6?
 
Registered: September 05, 2009Reply With QuoteReport This Post
  Powered by Social Strata  
 

Sponsors    Biodiesel and SVO Forums Home    Forums  Hop To Forum Categories  Diesel vehicles and other diesel equipment  Hop To Forums  6.6 Duramax    Medium Duty Duramax problems

© Maui Green Energy 2000 - 2014