BIODIESEL & SVO DISCUSSION FORUMS





Sponsors    Biodiesel and SVO Forums Home    Forums  Hop To Forum Categories  Diesel vehicles and other diesel equipment  Hop To Forums  GMC 6.2 and 6.5    96 6.5TD No hot start, SES and stalled today

Moderators: Shaun, The Trouts
Go
New
Find
Notify
Tools
Reply
  
96 6.5TD No hot start, SES and stalled today
 Login/Join
 
Member
posted
Hi friends,
Here's the checklist from DP site I filled out last night.

Any Ideas?

0. Describe in detail the problem you are having. Please be as descriptive as possible.

Recently I cone filtered, straight piped and put my FSD Cooler on the front bumper. After owning it 3 years.
It ran fine for a month.
Past week or so, it wont restart when sitting a bit.
And today, SES came on and stalled after making a spitting exhaust sound under my side of the engine.
I was low on fuel and made it into a gas station after a revival consisting of pulling the battery cables and purging the fuel filter.
While fueling (#2ULSD), I disconnected the batteries again and changed the fuel filter -it felt sticky but clean white as new-. Drove 5 more miles to home with no problems. LP is new.

1. Does the engine crank, or 'turn over'?

Yes.

1a. Does the engine start and run?

Yes, in the morning and after work, afraid to take it to lunch

1a1. If the engine does not start - Crack injector line: do you have fuel? Yes/No
1b. Do you have a Wait To Start Light & the amount of time (seconds) lit.

Yes, 5 seconds? when cold.

1c. Ambient Condition (temperature outside indicate F or C) _85° F
1d. Engine Cranking speed (if you have an accurate tachometer).

Normal

1e. Are you experiencing stalling?

Today it did on 10 mile commute home from work.
Hasn't stalled since the PMD was ontop the plenum.
Just died back then, no SES nor spitting.

1f. If Stalling, describe (upon startup only, down the road, hit a bump etc)

No bumps, down the road 120*F

1g. If Stalling, do you notice loss of dash or instruments?

No loss

-note if experiencing stalling,you must indicate PMD location in #24.

1h. Check turbo inlet and air filter for obstructions. Cone filters have lost disk and stopped air to turbo.

Seems fine

1i. In a no-hot start, pour a bottle of room-temp water on the injection pump. Does it start now? yes/no

No, tried it once a few days ago.

1.1 Lift pump test - describe results

Its new, but didnt test it the t valve. Purged fine, i guess during filter swap.

2. Service Engine Light while running?- on/off/intermittent

Came on on the road after noticing 'missing' feeling in acceleration. 5 miles after work.

2a. Service Engine light does glow during start/cranking/bulb check: Yes/No

Yes

3. Model year

1996

3a. Odometer reading (indicate if in miles or km)

252,000 miles


3b. Miles on major engine components if been replaced (example Injection pump)

Unknown

3c. Indicate the model number on the Injection pump (starts DS4 or DB2......)

No clue
4. Have you scanned for engine codes? (varies by pre/post 96) yes/no

About a week ago, but the battery cables were pulled to get home the night before.

5. List exact results on engine codes:

None, Batery load tests and alt- fine as well.

6. Air Filter condition (visual check)

New, clean and bright.

7. Fuel filter condition (freshly changed/condition unknown/mileage since changed)

No visible particles, white, but sticky feeling, not sure if Bio related.
I do a B20 blend with spec fuel. Kinda new filter, 2 weeks old.

8. Condition of Battery terminal connections (removed, cleaned and tightened)

Good and clean- no mods.

8a. Known condition and age of the batteries.

I've replaced one of them 1.5 yrs ago.

8b. Are batteries of differing age or are they a matched set?

Different, emergency situation.

8c. Condition of Major Grounds. (same drill as batt - removed, cleaned, retightened)

All good.

9. Upon cold start, does the radiator hose get hard quickly? Yes/no

No

10. Upon cold start, do you have excessive white smoke? Yes/no

No

11. Do you have excessive cranking time before the engine starts?

Not usually, when cold.

12. Have you used the block heater, and does this effect engine starting?(only try for starting problems)

Not lately

13. During hard acceleration, do you have excessive black smoke? Yes/no

No, not excessive, even less with CAI and pipe done.

14. Do you have any unusual exhaust smoke issues?

No

15. Turbo check out - pass/fail

I can hear the turbo spool, WG is stock and has vac.

16. Do you have an EGR on the engine? (An F or an S engine code 8th VIN digit)

F vin, do I have EGR? I dont think so.

17. Indicate if you know if it’s a 1500, 2500, 2500HD, 3500, 3500HD.

2500 Cheyenne

18. Indicate fuel that you are using: Bio-diesel, #2 Diesel, #1Diesel, SVO/WVO, other

#2 mostly since mods, havent had bio since before the mods.
Over a month ago.

18a. If running a VO (Veggie Oil fuel) setup, indicate details of your conversion (homemade, or packaged system)

19. Are you using any fuel additives? If so, please list.
No
20. Please indicate geographic region you are in: (example: Texas or Canada)
Southern Indiana
21. Do you have any service history available that might pertain to the problem you are having?
No, the recent mods are all Ive done.
22. Please indicate any modifications to the vehicle that might help us diagnose better.
Cant think of any.
23. Upon unscrewing the fuel cap, do you have a large vacuum formed in the tank? yes/no
Yes, some- not LARGE
24. Location of PMD/FSD? On the pump/remoted over intake/remoted out of engine bay (please specify placement specifically)
Under the front bumper.
24a. If remote mounted, describe wiring harness (homemade or purchased from a vendor?)
PMDCABLE.COM
24b. Indicate the location and condition of the FSD/IP grounding wire.
Intake
25. Are ALL glow plugs in proper working order as per this thread?
AFAIK

Whew!

Any help is appreciated .
Brian


1996 K2500 4x4 6.5TD
 
Location: Southern Indiana USA | Registered: June 20, 2008Reply With QuoteReport This Post
Member
posted Hide Post
I'm hoping it was the fuel filter,
the tank was near empty.
the filter seemed gummy, though it was still pretty white and clean of particles.

I have pressure at the filter purge.

Since running bio this year in a 13 year old truck, Ive changed 4 less progressively nasty filters.
This one is the whitest, tho slightly gummy.

I'll be glad to pull the tank before the IP.
This time it may need a shop.

Brian


1996 K2500 4x4 6.5TD
 
Location: Southern Indiana USA | Registered: June 20, 2008Reply With QuoteReport This Post
Member
posted Hide Post
Brian

-FUEL CAP!!!! unscrew the fuel cap see if this solves the problem. Cost me $800.00 to get that one solved. I know two others who hand the same problem Tom


" I don't know what I don't know until I know"
1994 GMC 6.5 Tubo 2005 Dodge ram 3500, 3 VW's 2000, 2002, 2005.
 
Location: Manitoba Canada | Registered: March 24, 2009Reply With QuoteReport This Post
Member
posted Hide Post
thanks tom,
I did actually try that too.
I had issues with the cap when I bought it and think I have a pretty good one.

I dont know what the deal is with this truck. I'm getting tired of the issues.
Today I got to work and back fine, except for my nerves.
Alot of my drive has no place to pull over.

Brian.


1996 K2500 4x4 6.5TD
 
Location: Southern Indiana USA | Registered: June 20, 2008Reply With QuoteReport This Post
Member
posted Hide Post
Well, Twisted Brown was towed off to a shop last night. Frown

The problem is definitely fuel delivery related.
I have fuel at the filter purge top, and at the water separator t-valve.

I cracked an injector line and got no wetness dribble while cranking.
I have an extra PMD relocated out of the engine bay on a heat-sink.
This is a common issue on these trucks and was hoping that was all I needed. Nope.

I'm dreading the phone call from the shop. An IP replacement will cost more than I paid for the truck.
The shop is a diesel shop, so I feel confident that they will know what they are doing.
Turns out the owner and I have alot of friends/associates in common and we hit it off well.
So I probly wont get jacked around.

It hasn't been driven since August. It stopped starting altogether.
It's 19*F outside now so it needed to be done. Can't regen my cooling system if it dosen't run and I miss the truck for driving.
I've been driving my 1976 one ton gasser. The 6.5 gets thrice the mileage per gallon than the smallblock.

Needless to say, I have a surplus of finished biodiesel and sold 2 330g totes of WVO to manage space.

Wow, 4 months since I heard the rumble and whistle. I had just deleted the muffler and cat, and added the cone CAI. It will feel like a whole new truck when I get it back. I'll update later.

$$$
Brian


1996 K2500 4x4 6.5TD
 
Location: Southern Indiana USA | Registered: June 20, 2008Reply With QuoteReport This Post
Member
posted Hide Post
Good news!
The IP is fine. Both PMDs are fine. Lift pump is fine.
Turns out I had a restriction at the tank. The sock filter strainer was loaded with sediment.

I stopped in the shop on my way home and they had just got the bed off. I got a look inside the tank and it was shiny metal under pristine fuel B-20ish I'm sure.

Im getting two new batteries from them and I think I found myself a good mechanic.
I'm glad it wasnt the injector pump, though I was starting to accept the fact that it may be the original with 250,000 miles on it.

Also turns out that they need some aluminum welding done. And guess what- I got a brand new Miller spoolgun.

I'm very happy. Big Grin

Brian


1996 K2500 4x4 6.5TD
 
Location: Southern Indiana USA | Registered: June 20, 2008Reply With QuoteReport This Post



member
posted Hide Post
Weldshop Hi, Have 2000 6.5 dully the computer under the intake went bad. Took 6 months to find what the problem was. The cost was about $600.00 Plus labor. Don't rember what that was. First time post. Carl


245T
 
Location: Iowa | Registered: December 19, 2010Reply With QuoteReport This Post
  Powered by Social Strata  
 

Sponsors    Biodiesel and SVO Forums Home    Forums  Hop To Forum Categories  Diesel vehicles and other diesel equipment  Hop To Forums  GMC 6.2 and 6.5    96 6.5TD No hot start, SES and stalled today

© Maui Green Energy 2000 - 2014