BIODIESEL & SVO DISCUSSION FORUMS





Sponsors    Biodiesel and SVO Forums Home    Forums  Hop To Forum Categories  Straight Vegetable Oil (SVO) as fuel  Hop To Forums  Single Tank Systems    Citroen Xantia 1.9TDi - First SVO use
Go
New
Find
Notify
Tools
Reply
  
Citroen Xantia 1.9TDi - First SVO use
 Login/Join
 
Member
posted
I used to run a Citroen ZX on SVO in a single tank system. I never blended the oil nor did I heat it - the fuel filter is already heated and I never had any problem with performance, even in very cold Scottish winter below freezing temperatures. I understand that using the engine in this way could have caused early failure, but I was and am happy with that risk and do not want to debate that decision here. The car eventually was scrapped for reasons of failed bodywork and suspension parts.

I now bought a Citroen Xantia which I use in Spain. I got this car as it shares the same engine type as the ZX I was so happy with. Again, I am prepared to take the risk of running the car, unmodified, on SVO. So I filled up for the first time last week. Air temperature was 35 to 40 degrees Celsius and initially the engine ran fine. I used the motor to charge some leisure batteries, tickover was perfect for 90 minutes, so I then went for a drive. Performance was fine for about 30 miles then dropped off. At tickover the engine speed modulates at something faster than 1 modulation per second, maybe dipping to about 500 rpm every 600 ms or so. Under load the engine runs out of power at about 2000 rpm, if I am climbing a hill the performance tails off at 1500 to 1800 rpm.

My guess is that the fuel is not flowing well enough either because the the viscosity iis way off, or I blocked the filter - or both. But, my previous Citroen coped just fine under much colder temperatures. It is very possible my heated fuel filter isn't actually heated. How can I check this? How best to fault find? I have about 40 litres of SVO in the tank and would prefer not to have to empty it.

Is it probable all my oil has gone through the filter in the 2 or 3 hours running time - mostly on tickover with only the alternator as load? So if there was a problem with my SVO filtering and I clean the car's filter out all should be well?

Thanks in advance.
 
Registered: July 12, 2010Reply With QuoteReport This Post
Member
posted Hide Post
Bosch or CAV pump.
 
Location: Nimbin Australia | Registered: December 04, 2007Reply With QuoteReport This Post
Member
posted Hide Post
I'd change the fuel filter, as changing to SVO for the first time drags sediment from the bottom of the tank. also, if it's not stalling, the engine revs "hunting" isn't anything to worry about, and normally lessens when it's fully warmed up.
 
Registered: January 11, 2014Reply With QuoteReport This Post
  Powered by Social Strata  
 

Sponsors    Biodiesel and SVO Forums Home    Forums  Hop To Forum Categories  Straight Vegetable Oil (SVO) as fuel  Hop To Forums  Single Tank Systems    Citroen Xantia 1.9TDi - First SVO use

© Maui Green Energy 2000 - 2014